gibbsie.org Knowledge Base

Cisco MDS 9000-series Fibre Channel fabric switches

Aug 3rd 2008
No Comments
respond
trackback

Cisco produce a range of MDS 9000-series fibre channel fabric switches, designed to provide functionality at every level from the small size through to the enterprise. All Cisco MDS 9000-series switches (with the exception of the MDS 9050 which is now end of life) run Cisco SAN-OS operating environment, which draws parallels with Cisco IOS for those more familiar with Cisco routers and switches.

General Device Commands

Elevating privileges to enabled mode: (note, this mode enables you to change the way the switch operates)
switch> enable

Enter initial configuration:
switch# setup

Show all modules:
switch# show modules

Show module inventory (more detailed):
switch# show inventory

Show power and temperature details:
switch# show environment

Display the date and time:
switch# show clock

Set the date and time:
switch# clock set 10:14:30 13 April 2007

Enter configuration mode:
switch# config t

Configuring and administering Licensing

Display port licenses:
switch# show port-license

Grant a license to a port
Specify the port interface:
switch(config)# interface fc1/1

Grant a license to a port or range of ports:
switch(config-if)# port-license acquire

Remove a license from a port or range of ports:
switch(config-if)# no port-license
switch(config-if)# exit

Saving the Running Configuration

Save the running configuration persistently:
switch# copy system:running-config nvram:startup-config

Create a startup configuration snapshot in a predefined location on the switch (binary file):
switch# copy nvram:startup-config nvram:snapshot-config

Back up the startup configuration copy in the bootflash: file system (ASCII file).
switch# copy nvram:startup-config bootflash:my-config

Back up the startup configuration to the TFTP server (ASCII file).
switch# copy nvram:startup-config tftp://172.16.123.234/my-config

Back up the running configuration to the bootflash: file system (ASCII file).
switch# copy system:running-config bootflash:my-config

Roll back to a snapshot copy of a previously saved running configuration (binary file).
switch# copy nvram:snapshot-config nvram:startup-config

Configuring and administering Configuration Synchronisation

This functionality is provided by CFS or Cisco Fabric Services. A troubleshooting guide is available here.

Display CFS status:
switch# show cfs status

Display CFS settings on an application-level:
switch# show cfs application

switch# config t

Globally enables CFS over IPv4 for all applications:
switch(config)# cfs ipv4 distribute

Globally disable CFS over IPv4 for all applications:
switch(config)# no cfs ipv4 distribute

Configuring the Out-of-Band Management Interface

Setting the Out-of-Band Management interface port speed, duplex and IP configuration:
switch# config t
switch(config-if)# interface mgmt0
switch(config-if)# switchport speed 100
switch(config-if)# switchport duplex full
switch(config-if)# ip address 192.168.254.22 255.255.255.0
switch(config-if)# exit

Configuring and administering Fibre Channel Interfaces

Display interface configuration:
switch# show interface
switch# show interface brief

Configuring multiple interfaces at a time:
switch# config t

Selects a single FC interface for configuration:
switch(config)# interface fc1/1

Alternatively, select a range of FC interfaces for configuration:
switch(config)# interface fc1/1 - 4 , fc2/1 - 3

Setting interface mode:
Configures the administrative mode of the port. Valid setting for the operational state are: auto, E, F, FL, Fx, TL, or SD port mode. These values have special significance within Fibre Channel so ensure you set the correct port mode if setting an interface to a particular port mode.
switch(config-if)# switchport mode F

Alternatively, configure the interface mode to auto-negotiate between an E, F, FL, or TE port mode (note that auto does not support TL or SD port modes) of operation.
switch(config-if)# switchport mode auto

Setting interface speed:
switch(config-if)# switchport speed 4000
Where the value after the speed declaration is either auto (automatically negotiate the port mode), 1000 (1 Gbps), 2000 (2 Gbps) or 4000 (4 Gbps)

Configuring and administering Trucking

Check to see if trunking is enabled:
switch# show trunk

Enable the trunking protocol: (note, this is enabled by default)
switch(config)# trunk protocol enable

Disable the trunking protocol:
switch(config)# no trunk protocol disable

Enables (default) the trunk mode on the interface:
switch(config)# interface fc1/1
switch(config-if)# switchport trunk mode on

Disables the trunk mode on the interface:
switch(config)# interface fc1/6
switch(config-if)# switchport trunk mode off

Negotiate the trunk mode operation on a specific interface:
switch(config)# interface fc1/22
switch(config-if)# switchport trunk mode auto

Change the trunk allow list for a specific interface to a specific VSAN: (this example uses VSAN 1)
switch(config-if)# switchport trunk allowed vsan 1

Add a specific VSAN to the trunk allow list on a specific interface: (this example uses VSAN 44)
switch(config-if)# switchport trunk allowed vsan add 44

Configuring and administering Port Channels

Display a summary of the port-channels:
switch# show port-channel summary

Display all port-channel database entries:
switch# show port-channel database

Force a specific FC interface as a member of Port Channel 1:
switch(config)# interface fc1/1 - 2
switch(config-if)# channel-group 1 force

Configuring and administering VSANs

Display all VSAN information:
switch# show vsan

Show configured domain ID (needed for some configuration options) for a specific VSAN:
switch# show fcdomain vsan 20

Configuring a VSANs to a specific domain ID: (note, the domain ID is listed using the previous example)
switch# config t
switch(config)# fcdomain domain 106 static vsan 20
switch(config)# exit

Listing all Fibre Channel Devices Known to the Fabric

Display FC devices known to the switch:
switch# show fcns database


This post is tagged , , ,



Explore Recent



Monthly Archives



No Comments

Leave a Reply